Back to overview
Downtime
The problem with the website was identified.
Aug 19, 2024 at 8:34pm UTC
Resolved
Sep 1, 2024 at 1:09pm UTC
Resolved
Affected services
Updated
Aug 20, 2024 at 12:44am UTC
A fix has rolled out now. The website is in a testing phase
Affected services
Updated
Aug 19, 2024 at 11:38pm UTC
We are working tirelessly to get the website up and running. The problem is with one of the functions.
Affected services
Created
Aug 19, 2024 at 8:34pm UTC
A temporary fix was issued while we work on getting everything back up and running.
Affected services